HomeLab: Let’s connect, A Networking post, woo.

Thanks to my gorgeous daughter I woke Friday morning with a nice enjoyable cold. Not wanting to waste my weekend, it decided it was time…

Bring on the networking!

As you’ll soon see, it may be overcomplicated and in many ways unnecessary. However a lab Is to learn and boy am I learning!

It all begun with this little screen late Friday night…

Vyos Installation Screen

Yep, I started with the wrong ISO…  That was the beginning of a challenging weekend; Unfortunately not all the obstacles I faced were as simple to rectify as this.

After installing Vyos, I put the machine aside and moved on to the next.


Workbench with networking devices

Starting with what I know very well, I proceeded to build the new PfSense firewall Box. It’ll be nice to finally have this running on a machine with AES-NI (I’ll do a post specifically about all the hardware later,) but with that done it was time to set up the trusted network between the PfSense firewall and the LB4M.

I’ll openly admit, networking isn’t high on my skillset. I understand more than enough to keep me going, but once you throw me into cli based systems and expect me to sort it out… I’ll wing it,  usually I succeed but it takes time haha.

So as it ticked past 3am and id still not managed to get the (VLAN) traffic to flow through the LAG between the firewall & switch it dawned on me…

brainfunction.mrc
on:action:yawn:*: {
if ($tired == 1) {
goto sleep
}
else {
echo justkeepswimming.gif
}
}

Yep… A mIRC reference, showing my age.

So, I went to I bed.

One very poor sleep and 3 hours later and I was back at it. Thinking my issue was possibly due to the firmware on the LB4M I decided to try a few different ones, with no success… Fuck it I’ll worry about that later.

As I pushed the LB4M aside and plugged back into the VYos router and PfSense firewall I worked on understanding Vyos; Having not had much exposure it, it was a bit to wrap my head around; I do however, much prefer working Via CLI than a GUI. I got the VLAN for trusted network to PfSense sorted Out — Then it was time to configure the DMZ switch VLAN.

But being that it’s now 1am, I’m off to bed hopefully to actually sleep and enable me to function tomorrow!

Success, smashed a few solid hours of sleep and back to it again… Well, not before spending time with my daughter playing with the new Doll House her Nanna bought her (someone has Daddy wrapped around their little finger!).

Oddly enough, configuring the Dell switch gave me a few ideas about where I went wrong with the LB4M. With every intention to move on to that I realised that the device running vyos was getting a little Toasty… This was with the lid open and the aircon at 22 degrees blowing straight on top of it, so I had to divert my attention to this.  However being a 1U case (older checkpoint gateway) this was not going to be a simple fix.

After thinking about this long and hard I had a solution, it involved a big old fan and a drill! Oh, and doing away with the old 500gb spinner and replacing it with a 16gb Sata Dom to give me space to install said Fan. Yep vyos needed to be reinstalled…

Again…

Backup, reinstall, restore, didn’t quite work… About 30 minutes later & a bit of google fu,  I figured out why I wasn’t successfully passing traffic over the DMZ VLAN and things were going well again.

As I don’t like using console cables if I can avoid it I pull the mobo out of the checkpoint and plug in an old pci graphics card to complete the installation, this was about the 10th time I’ve done this (obviously was also a requirement to drill the holes as earlier mentioned but that’s not the point) ANYWAY, Now to the point…

This time I noticed more jumpers than I’d ever noticed before, these instantly caught my attention as about a year ago I replaced the factory shipped 1.5ghz celeron with a 2ghz pentium but it was always reporting as 1.5ghz at a lower speed and nothing in bios would allow me to rectify this so I just ignored it back then.

Well, with the jumpers moved I now have 2ghz processor available and at a higher clock speed, good times (now if only I could get it to run with more than 2gb of ram!)..

Great, lets put it all back together and make sure It works, I lean over place my hand on the case, push the power lead back In…

*ZAAAAP* – room goes very quiet-
*WHIRRRR* – UPS fans kick in-

I’d placed my palm ever so slightly on the power in to switch bus bar and electrocuted myself! Small 240v charge definitely wakes you up! This isn’t the first and I’m sure won’t be the last time; I’m greatful for RCD’s, I don’t want to die setting up a homelabs networking infrastructure.

After flicking the RCD back on It was back on to it, powered everything back up and checked all was good…  that was enough for today.

I’m officially a networking Jesus (one step from being god, I think? Was never good with Christian stuff).

Well jesus, that was a long rant, if you made it this far I commend you.

One last note, still not overly happy with how cool the pfsense box runs…  I’ll need to investigate more later I think, probably not actually cos it’s okay.

Until next time, goodbye!

 

 

Posted by Brendan

An IT system Administrator from Australia, technology guru and Automotive enthusiast/wanna be mechanic.

Leave a Reply

avatar
  Subscribe  
Notify of